For phone compatibity, the phone must a cellular or Wifi connection to the Internet and Bluetooth Low Energy 4.0 technology.  The minimum operating system requirements are:

  • Android OS 4.3
  • iPhone OS 7.1

For Android, some carriers offer updates to the Operating System, You will have to check with your carrier to determine if an update is available.

In general, today's Android smart phones are compatible with PayRange.  If you are having trouble with the PayRange app, on your Android phone there are some things you can check.  

For specific device support:

Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.